We are currently experiencing interruptions to some Visier services.

Incident Report for Visier Detailed

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 10:18 UTC

Monitoring

The services from our infrastructure provider seem recovered, we are monitoring our system.
Posted Oct 20, 2025 - 09:41 UTC

Identified

The issue impacting one of our basic infrastructure providers has not been resolved. At this moment, more services in the US region are being impacted.
Posted Oct 20, 2025 - 09:10 UTC

Investigating

Please note that some customers may currently be experiencing an interruption to their Visier services. We are actively working on resuming all services to normal. We apologize for any inconvenience this may have caused. Thank you for your patience.
Posted Oct 20, 2025 - 07:22 UTC
This incident affected: Data Processing - US (Scheduling - US, Connectors - US, Processing - US, Uploading - US), Visier People - US (Studio - US, Workforce Planning - US), and Vee - US, Skills Intelligence Engine API, Compensation Benchmarks API.