We are currently experiencing an issue with multiple auxiliary Visier Services in the US region

Incident Report for Visier Detailed

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 19:50 UTC

Identified

Data Products API and Compensantion Benchmarks UI are back online. E-mail sending it's recovered as well. We are still having issues with SFTP uploads.
Posted Oct 20, 2025 - 18:28 UTC

Update

Our infrastructure provider is still having issues, and some other Visier Services are impacted. Currently Data Products API, Compensation Benchmark UI, SFTP Uploads, and EMail delivery are impacted.
Posted Oct 20, 2025 - 17:44 UTC

Investigating

Please note that some customers may currently be experiencing an issue with our Data Products services, such as Skills and Compensation Benchmarks. We are actively working with our infrastructure service provider on resolving the issue. We apologize for any inconvenience this may caused.
Posted Oct 20, 2025 - 14:45 UTC
This incident affected: Data Processing - US (Uploading - US) and Compensation Benchmarks, Skills Intelligence Engine API, Compensation Benchmarks API.